We're sorry GroupDocsCloud doesn't work properply without JavaScript enabled.

Free Support Forum - groupdocs.cloud

Can't convert password protected xls and ppt

In the latest GroupDocs version, I tried to convert password protected ppt and xls and got the following error:
{“requestId”:“b2d6ca33-0e4c-45c8-a27e-de224cc99dff”,“error”:{“code”:“internalError”,“message”:“Conversion from () to pdf PDF is not supported.”,“description”:“Operation Failed. Internal error.”,“dateTime”:“2023-04-23T10:50:38.6584461Z”,“innerError”:null}}​

my request:

“FilePath”: “password_protected_xls.xls”,
“Format”: “pdf”,
“OutputPath”: “converted/password_protected_xls_converted.pdf”,


Container execution:
docker run -p 8080:80 -v $(pwd)/data:/data --name conversion_cloud groupdocs/conversion-cloud

Attached are the example files. (password: “test”)

This issue is urgent, as we supply our solution based on these abilities to our customers.​

Thank you, Dani.​

Archive.zip (52.6 KB)


Please use the LoadOptions object and set the password property accordingly. It will resolve the issue.

Hi Tilal.
In our application, we first send the request with empty password:

    "LoadOptions": {
			"Password": "",
			"SkipEmptyRowsAndColumns": false

and if it fails, we send request to “/v2.0/conversion/info”, and decod it’s content, and look for boolean “IsPasswordProtected”.

this is the request we send:
when we try to get the info of a password protected “doc” (for example) we get the boolean “isPasswordProtected” as true. but with the file I supplied (password protected xls and ppt), we get the following:

            "fileType": "",
            "pageCount": 1,
            "size": 210432,
            "width": 0,
            "height": 0,
            "horizontalResolution": 0,
            "verticalResolution": 0,
            "bitsPerPixel": 0,
            "title": "",
            "author": "",
            "createdDate": "2023-04-24T13:11:21.1696387Z",
            "modifiedDate": "2023-04-20T09:08:11Z",
            "layers": null,
            "isPasswordProtected": false

“isPasswordProtected is false”.
and, then our flow breaks.



Thanks for the additional information. We have noticed the reported issue and logged a ticket (CONVERSIONCLOUD-507) for further investigation and rectification. We will update you as soon as it is resolved.

Hi Tilal,
Any progress on the issue?

  1. Im not sure how to follow the progress using the ticket number you gave me.
  2. This issue is a major blocker for us and our users. can you provide us the image number before the change with the degradation was merged?


I am afraid you cannot access our internal tracking system. You can check the progress of the ticket in the issue status box at the right bottom of the thread. And can also ask us in the thread for the update.

After initial investigation, we have noticed that an issue exists in the parent on-premise API GroupDocs.Conversion for.NET. So we have logged an internal ticket to fix GroupDocs.Conversion for .NET the first place. Later, we will export the fix to the GropDocs.Conversion Cloud API as soon as the issue is resolved. We will keep you updated on the progress of the problem resolution.


We cannot wait for the issue to be resolved. Please provide us with a SHA256 hash of a working GroupDocs.Conversion Cloud Docker image, a version before this breaking change was introduced.

Thanks, Dani.


We have noticed that the GroupDocs.Conversion Cloud 23.2 does not contain the issue so we have uploaded a tagged Docker image v23.2 for you. So you may use this image until we fix the issue in the latest release.

Hi tilal,
Any updates on this matter? we currently use 23.2, but it’s not supporting DXF and we want to upgrade. latest version have this fix?

Thanks, Dani.


I am afraid the issue is still not resolved. However, we have raised the issue priority in our issue tracking system and will share an update as soon as possible.

Hi tilal,
Do you have TTL?


The issue is more complex than expected. It is still not fixed in GroupDocs.Conversion for .NET API. I have requested an ETA and will notify you as soon as I get an update.

The issues you have found earlier (filed as CONVERSIONCLOUD-507) have been fixed in this update. This message was posted using Bugs notification tool by sergei.terentev