We're sorry GroupDocsCloud doesn't work properply without JavaScript enabled.

Free Support Forum - groupdocs.cloud

DXF to PDF Conversion in GroupDocs.Conversion Cloud Docker throws internalError

Hello, I tires to convert .DXF files to PDF as follows:
create the container:
docker run -p 9080:80 -v /data:/data --name conversion_cloud groupdocs/conversion-cloud

with the attached DXF files, but got “internalError”, with “Object reference not set to an instance of an object.”. the same approach worked with other files types.
Archive.zip (4.3 KB)
Archive.zip (4.34 KB)

We have tested DXF to PDF conversion with your shared files and noticed the reported issue. So opened the following new ticket(s) in our internal issue tracking system and will deliver their fixes according to the terms mentioned in Free Support Policies.


You can obtain Paid Support Services if you need support on a priority basis, along with the direct access to our Paid Support management team.

The issues you have found earlier (filed as CONVERSIONCLOUD-500) have been fixed in this update. This message was posted using Bugs notification tool by sergeiterentev

I tested DXF conversion with the latest version, and the output for PDF is an empty file.
attached are the original file, and the converted file.
I performed the conversion as stated above.
Archive.zip (50.2 KB)


Please double check that you are using the latest release. I converted your shared DXF to PDF using the latest version of GroupDocs.Conversion Cloud Docker 23.7 and was unable to notice the reported issue.

dxftopdf_Docker.pdf (49.1 KB)

I tried again.
I did as follows:
docker pull groupdocs/conversion-cloud
docker run -p 8080:80 -v $(pwd)/data:/data --name conversion_cloud groupdocs/conversion-cloud:latest

and got:
Failed to set license /data/test.lic.
System.IO.FileNotFoundException: Could not find file ‘/data/test.lic’.
File name: ‘/data/test.lic’
at Interop.ThrowExceptionForIoErrno(ErrorInfo errorInfo, String path, Boolean isDirectory, Func`2 errorRewriter)
at Microsoft.Win32.SafeHandles.SafeFileHandle.Open(String path, OpenFlags flags, Int32 mode)
at Microsoft.Win32.SafeHandles.SafeFileHandle.Open(String fullPath, FileMode mode, FileAccess access, FileShare share, FileOptions options, Int64 preallocationSize)
at System.IO.Strategies.OSFileStreamStrategy…ctor(String path, FileMode mode, FileAccess access, FileShare share, FileOptions options, Int64 preallocationSize)
at System.IO.Strategies.FileStreamHelpers.ChooseStrategy(FileStream fileStream, String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options, Int64 preallocationSize)
at System.IO.FileStream…ctor(String path, FileMode mode, FileAccess access)
at GroupDocs.Conversion.Cloud.Config.LicenseInitializer.InitLicenseFromFile(String licensePath, ILogger logger) in /build/src-microservice/GroupDocs.Conversion.Cloud/Config/LicenseInitializer.cs:line 23

In addition, attached is the pdf output of the conversion, the original file, and screen-shot of the error, the original and the result.
I also attempted to convert it with a license and the result was still empty.
What am I doing wrong?


Please share your sample conversion code with us as well.

Hi tilal.
I tried again and succeeded converting a dxf file. thank you

1 Like