Free Support Forum -

PDF file takes forever to load in GroupDocs.Viewer Cloud embedded viewer

Greetings again,

I have come across a PDF file that fails to load in the GroupDocs Cloud Viewer. You can download it here: It is a fairly small file; 1.3MiB.

It fails to load regardless of any quality settings I specify when creating my iframe. Any ideas on what could be causing this?

Hello Nick,

Thank you for the request and we are sorry to hear that you have such issue. We have tried to view your pdf and it rendered well for us. Since that could you please provide more info: URL which you use for iframe, your use-case and code example of the uploading and embeding.

Thank you.

Hi again,

Here is the source code, as you requested. When I try to view this document, this is the error I get. It is 100% reproducible on my end.

As for my company’s use-case, we allow our users to upload a variety of files (text, rich-text, pdf, excel spreadsheets, image files, and others) for sharing with their colleagues. PDFs of this nature are not particularly unusual for our user-base, so it’s concerning that this one doesn’t load.
Hello Nick,

Thank you for the details.

Yes, we have managed to reproduce the issue on our side. We have logged the same issue earlier with other our customer. Our Product team has fixed it already, but a fix still not released yet. We have added a ticket number (WEB-2145) to this thread . When the fix of this issue will be released you will be notified.

We apologize for the inconvenience.


Best regards,
Evgen Efimov
Your Document Collaboration APIs
Follow us on LinkedIn, Twitter, Facebook and Google+